Create new plugin fails to connect to config screen

Hi! Following the steps in we have tried to create a test plugin but it’s not connecting to the config screen set up.

The project created with the provided command, when started, shows this:

Compiled successfully!

You can now view conditional-disable-fields in the browser.

  Local:            http://localhost:3000

Note that the development build is not optimized.
To create a production build, use npm run build.

webpack compiled successfully
No issues found.

But the Dato interface shows this error, and not the expected config screen:

Plugin settings

The plugin at http://localhost:3000 is not responding correctly after 20 seconds.

The entry point we put for the plugin on the Dato plugin create pop up was : http://localhost:3000 .

Not sure where the error is.

Hello @technology

This is probably due to an error in the private plugin configuration, can you send us over the project URL and the plugin repository at so we can take a closer look? Thank you!

There really isn’t anything to send. All we did was:

  1. In DatoCMS click on the + sign and create the plugin
  2. command line: npx create-react-app@latest conditional-disable-fields --template datocms-plugin --use-npm

@technology , and the private plguin page is as such?

If so, could you send us any console output you may have in your browser from the plugin page?

Indeed, the same as your image when we created it (we didn’t toggle the Legacy plugin option)

In that case then the problem must be in the connection from the local endpoint and the browser:

An easy way to see if that is the case is trying to load the plugin using a different browser (specially if you use safari)