Wrong JSON format after update

Hey - I just updated to latest gatsby and latest datocms-source, and now my content from datocms json fields is fetched in a wrong format (I suppose):
{
en: ‘{\n’ +
’ “PARTIALS”: {\n’ +
’ “HEADER”: {\n’ +
’ “CART”: “Cart”,\n’ +
’ “ACCOUNT”: “Account”,\n’ +
’ “LOGOUT”: “Log out”\n’ +
’ },\n’ +
’ “FOOTER”: {\n’ +
’ “ADDRESS”: “Address”,\n’ +
’ “CONTACT”: “Contact”,\n’ +
’ “FOLLOW”: “Follow Us”,\n’ +
’ “LANGUAGE”: “Language”,\n’ +
’ “CURRENCY”: “Currency”\n’ +
’ }\n’ +
’ },\n’ +
… etc

image

Hello @anders

sorry for that :frowning:

Have you tried rolling back to the previous gatsby-source-datocms that was working? Can you please report on which version were you before the update?

No I didn’t try to roll back - would like the latest version as I try to keep deps up to date once in a while :slight_smile: The latest version that worked was version “2.3.0” as far as I can see.

sure, but maybe can you just try to roll back our source plugin to check if the problem is there or somewhere else?

It worked prior to upgrading and I did a yarn upgrade gatsby-source-datocms in order to get the latest, so the problem came after upgrading. And I have done a fresh install of node modules.

can you maybe share the access to your repo? feel free to reach out via PM (i’m matjack1 on github)

You should have access to a temp repo now :slight_smile:

If I should try master, than it’s working fine here :slight_smile:

I’m with node v12.13.1 and you?

The solution is set to run v15.5.1. Did you update gatsby-source-datocms to the latest? I actually used 2.3.0 again since I needed it to work.

Try to remove it and install the latest version and see what happens.

let’s follow up on your repo, ok?

1 Like