Using the "Deploy with DatoCMS" Button

Hi there,

I’m trying to setup a project with the “Deploy with DatoCMS” button. I’m using this linke “https://dashboard.datocms.com/deploy?repo=mmintel/gatsby-starter-indiegram” which links to this repo https://github.com/mmintel/gatsby-starter-indiegram. I’ve added a datocms.json file which contains

{
  "name": "Indiegram",
  "previewImage": "https://github.com/mmintel/indiegram/blob/master/preview.jpg?raw=true",
  "templateId": "22000",
  "deploymentType": "netlify",
  "netlifyBuildCommand": "gatsby build",
  "netlifyBuildDirectory": "public"
}

When I click on the button it takes me to DatoCMS, asks for my Github and Netlify and when I want to create I am getting an genericError.NOT_FOUND error. Not sure what’s wrong here, probably the templateId field of my config?

I was guessing I could use the id that I see in my projects URL on the DatoCMS Dashboard (https://dashboard.datocms.com/project/22000) => 22000. Is that wrong?

hello @marc

unfortunately that is still not something that we have exposed, so I need to do that manually. But we want to make this public soon :slight_smile:

So now your project should work, can you please try again and let me know?

Thank you!!

Thanks a lot! Great to know that it’s coming soon :slight_smile: I love that feature.

I just tried and it went a step further, but stuck at this "genericError.Error from Netlify: “failed during stage ‘building site’: Build script returned non-zero exit code: 1"”

Hello @marc this should be fixed now. Please be in touch if you still have any issue! Sorry for that

@mat_jack1 Unfortunately that error still exists :frowning: but thanks for investigating!

Hello @marc I just tried but the error is from Netlify. You need to make sure the build there passes correctly. The template project on DatoCMS is working as expected, I think :slight_smile:

@mat_jack1thanks you were right! although I was only able to see this while recording my screen as the message in the netlify logs is immediately hidden :smiley:

damn! Glad you sorted that out though :wink: