User can unintentionally delete unsaved records (most of the time!)

When you click on the name of a model while creating a new record you get redirected to edit the model without a warning that you’ll lose your progress, sometimes that is!

If you fill in some (required) content then you’ll get this:

Conditions that do not produce ‘discard changes’ dialog box.

  1. Fill out the record with all requirements met (able to save).
  2. Fill out the record with all requirements met, then delete some of the required content (not able to save).
  3. brand new record with no content (unable to save)

I can produce a video of this behavior

-Aaron

1 Like

thank you @escmattresscenter for the feedback!

Can you please specify on which browser are you? We had some issues popping up the warning on certain situations. So that would help.

We’ll make sure to improve that though, you are right :frowning:

Yep @escmattresscenter, the best thing would be sharing a video with the error. I tried reproducing it (on your Mattress model) but I couldn’t :grimacing:

@s.verna

Sorry the quality of the video suck but hopefully, this will give you an idea of what I’m talking about.


When the user clicks on a field’s name to the right (like in the original picture I posted). The ‘discard changes’ dialog box pops up when you haven’t completed all the requirements of the new record. Once requirements are met then the user clicks on the field’s name no dialog box is displayed, and unsaved changes are lost.

This behavior seems to happen when no fields are filled out on a new record and if the user meets all requirements but, then deletes the content from a required field.

Tested on Chrome 76.0.3809.132

@mat_jack1 Do you need anything else from me on this issue?

no thank you @escmattresscenter

we are finalising some new features coming up and then we’ll do a round of fixes! I’ll be in touch, sorry for the delay :frowning:

1 Like

@escmattresscenter we have tried reproducing now the error and it doesn’t happen to us. Can you please try again? We have done some code changes in that area these days and it might be fixed already, can you please confirm?

Thank you very much