Typing in Markdown editor makes the Dato interface jump/scroll/glitch

Describe the issue:

  • Please include any relevant error messages, screenshots, and troubleshooting you’ve already tried.
    Video of the problem:

The block in question:

As far as we know, the problem only arises with this particular block. I haven’t tried much in terms of troubleshooting as I don’t really have any clue as to what could be causing this.

Could this be a bug from your (Dato’s) end?

Hi @henri,

I tried to replicate this on my side using a similar schema, but couldn’t quite get it to happen. Could you let us know which project this is in, please? (Feel free to DM me or email support@datocms.com if you don’t want to share the URL publicly). With your permission, I’d like to fork your project into a sandbox and try to make it happen there?

It might have something to do with either the block nesting and/or the validation limits (limit of 1 image block?), but I can’t be sure without seeing the error happen.

Also, does this happen regardless of browser and viewport (window) sizes?

Thanks, and sorry about the issue! We’ll try to debug it once we can see it happening.