Prevent LSEP character from rendering on Windows using Chrome

Hi,

On Windows using the Chrome Browser, the LSEP character renders. The typeface for the solution is set in Inter.

I was just curious how would I go about removing this character? Should I remove it using javascript or do a find/replace on the data in the CMS. If I have to do a find/replace what’s the best way to go about it?

Warmest, Carl.

Hello @solutions

Can you provide a screenshot from where the character is rendering and you wish to overwrite it?

Hi m.finamor

Attached herein are the screenshots. It might have something to do with multi-text. The field is multitext. Basically have that character (LSEP) removed or formatted accordingly.

Warmest, Carl.

lsep-characters

The LSEP Characters

Warmest, Carl.

Thank you for the clarification!
It seems like the input on that field has a LSEP character inserted (probably unintentionally pasted from somewhere else)
The way to go here should be, as you said, to replace it.
Using a simple regex replace like .replace(/
/g," ") should solve it

If you are setting that field through the CMA, sanitising the input before with that method should avoid it to be inputed into the CMS itself

Hi m.finamor

The regex seems to make sense.

Is it possible for the DatoCMS admin to go about applying that regex filter [Like a plugin or a setting of some sort]? Or is it just meant to only done on the front-end?

I also noticed that this happens on multi-line text (so perhaps converting it into single-line text or structured field would be the way to go about it).

Warmest, Carl.

Hello Carl,

Unfortunately we can’t do this on a global level for the entire website, as some people would want the behaviour of rendering that character, but as you mentioned, the creation of a custom plugin that filters out that character from the field value could be created using our SDK: Plugin SDK - Field extensions - DatoCMS Docs