Error on adding Zeit as a deployment environment

When I try to add Zeit as a deployment, after the oAuth phase on Zeit, I select the Zeit project I want to add, the branch and I get this error on a popup:

Error creating hooks: TypeError: Cannot read property 'post' of undefined

Then it hangs and doesn’t save the deploy environment.

On Zeit, though, I got a webhook:

Cheers and thanks! :pray:

Ciao @g.demartino :wink:

can you please try again? Should be fine now!

Ciao @mat_jack1, nope , I got the same error even after logging out/in…

Hi! There was indeed a small bug. Should be fixed now!

Ciao, unfortunately I still got the error popup but with a new error this time: Error creating hooks: TypeError: Failed to fetch

Same here

Sorry, I cannot reproduce. Can you describe what are you trying to do and which project are you working on?

I got a nextjs page that uses unstable_getStaticProps to fetch datocms at build time, if I want to add an environment in datocms and connect it to my nextjs project a get the error message mentioned but in the build hook is created

Never mind, works now, thanks!

1 Like

It’s working for me as well!
Thanks for the support, we can close this issue.


1 Like