Default image alt and title not appear in HTML editor

I did add the default alt and title attributes for images in the media section but it seems like these attribute are not being added when select image from media in html editor. Is this a bug or dato not supporting this yet ?

Hi @sangsangdt25 it should work. It is a recent introduction. Make sure you filled in the alt / title for the right locale, otherwise can you make a screen recording showing the bug?

I only have one locale in the projects setting, am not sure it’s a bug or not.

The default alt and title in media area:

The html return by the api doesnt have any alt or title in it:

the field using the images is a Multiple-paragraph text field with html editor.

hi @sangsangdt25 I forgot to mention that you have to add alt/title before inserting the image in the html editor. Changing alt/title in the media area afterwards, won’t change the alt/title in the records.

Please try again removing the image from the editor and adding it back. It should work now :slight_smile:

1 Like