[Bug] Editor is unusable in Korean


The bug is that, when typing Korean in structured text fields, the text looks like it’s typed but it isn’t recognized by the app and just disappears randomly (which seems like a preview from IME I suspect), can’t type space or any other punctuation marks, can’t delete characters, sometimes it just types out twice or more and it’s an absolute annoyance to use in general.

Could you take a look at this issue? it is currently the only blocking reason for me to adopt Dato CMS.

I confirmed this issue persists without Grammarly extensions, and I’m using Firefox 96.0.3 on Windows 11.

I was able to reproduce this issue on Chrome (albeit it’s Canary 100.0.4871.0, no extensions installed) and in fact it’s much worse on Chromium browsers.


Hello @basix

I tried reproducing the error locally but i wasn’t able to. I tried on Chrome and Firefox latest versions on MacOS and on chrome on Windows 10, but i wasn’t able to encounter the problems in any version.
Could you send a detailed step by step on how to get to that problem so we can eliminate some possible variables?
Specific keys or key combinations to press, or a specific string that triggers it would be helpful.

Thank you!

Hi, after spending some time with this bug I noticed this bug happens only when you create a new paragraph (usually I prefer to call this a block but that has totally different meaning here so) by Korean character. After any non-Korean character has been typed the editor behaves normally.

Thank you for looking into this, @m.finamor !